yacy fail nach upgrade mit debian

Keine Scheu, hier darf alles gefragt und diskutiert werden. Das ist das Forum für YaCy-Anfänger. Hier kann man 'wo muss man klicken' fragen und sich über Grundlagen zur Suchmaschinentechnik unterhalten.
Forumsregeln
Hier werden Fragen beantwortet und wir versuchen die Probleme von YaCy-Newbies zu klären. Bitte beantwortete Fragen im YaCy-Wiki http://wiki.yacy.de dokumentieren!

yacy fail nach upgrade mit debian

Beitragvon veto » Di Mai 27, 2014 5:20 am

hi,
gerade der zweite server wo yacy nach upgrade nicht mehr startet.
ein /etc/init.d/yacy restart geht auch nicht mehr
hier die meldung nach einem apt-get upgrade



Setting up yacy (1.73.9056) ...
Starting YaCy P2P Web Search: failed.
invoke-rc.d: initscript yacy, action "start" failed.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
E: Sub-process /usr/bin/dpkg returned an error code (1)
veto
 
Beiträge: 12
Registriert: So Mai 12, 2013 2:08 am

Re: yacy fail nach upgrade mit debian

Beitragvon Orbiter » Di Mai 27, 2014 5:48 am

Das einzige was tiefgreifend anders ist, ist die Dependency auf Java 7. Das müsste da aber automatisch nachgezogen werden.

Gucke bitte mal was in /var/log/apt/term.log steht
Orbiter
 
Beiträge: 5784
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: yacy fail nach upgrade mit debian

Beitragvon lux » Di Mai 27, 2014 9:42 am

Hi,

ich hatte kürzlich einen ähnlichen Fehler nach der Installation desDebian-package auf einem RaspberryPi, weil 'openjdk-7-jre-headless' nicht installiert war. Ob das hier auch der Fall ist - vielleicht.

Gruß
lux
lux
 
Beiträge: 42
Registriert: Sa Jun 01, 2013 9:49 am

Re: yacy fail nach upgrade mit debian

Beitragvon Guims » Di Mai 27, 2014 4:09 pm

Same error for me.
And today i have an error on debian.yacy.net
Forbidden
You don't have permission to access / on this server.
Guims
 
Beiträge: 40
Registriert: Mo Sep 02, 2013 5:03 pm

Re: yacy fail nach upgrade mit debian

Beitragvon Orbiter » Di Mai 27, 2014 5:46 pm

Guims hat geschrieben:And today i have an error on debian.yacy.net
Forbidden
You don't have permission to access / on this server.

:oops: fixed that right now, sorry.

Is there anything in /var/log/apt/term.log which could give a hint what went wrong?
Orbiter
 
Beiträge: 5784
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: yacy fail nach upgrade mit debian

Beitragvon Guims » Di Mai 27, 2014 7:03 pm

Hello Orbiter.

Thx for debian.

I post the last line of term.log
Sorry it's in french

Préparation du remplacement de yacy 1.73.9059 (en utilisant .../yacy_1.73.9060_all.deb) ...
not running.
Dépaquetage de la mise à jour de yacy ...
Paramétrage de yacy (1.73.9060) ...
Starting YaCy P2P Web Search: failed.
invoke-rc.d: initscript yacy, action "start" failed.
dpkg: erreur de traitement de yacy (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
yacy
Guims
 
Beiträge: 40
Registriert: Mo Sep 02, 2013 5:03 pm

Re: yacy fail nach upgrade mit debian

Beitragvon Orbiter » Di Mai 27, 2014 7:22 pm

thank you! hm, that does not give more info. But I found a dependency problem in the debian configuration which was not updated after the migration to java 7. Please try an update again :roll:
Orbiter
 
Beiträge: 5784
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: yacy fail nach upgrade mit debian

Beitragvon Guims » Di Mai 27, 2014 7:31 pm

Unfortunately apt-get update && apt-get upgrade does not change.
0 update

I tried to remove and install again yacy .... but it's not succefull.
I do not have yacy in /etc/init.d ( yacy: unrecognized service )
I have no other idea
Guims
 
Beiträge: 40
Registriert: Mo Sep 02, 2013 5:03 pm

Re: yacy fail nach upgrade mit debian

Beitragvon Guims » Di Mai 27, 2014 7:40 pm

Paramétrage de yacy (1.73.9060) ...
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/yacy/cora /order/Base64Order : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14 2)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: net.yacy.cora.order.Base64Order. Program will exi t.
dpkg: erreur de traitement de yacy (--configure) :
le sous-processus script post-installation installé a retourné une erreur de

I have this error when i retry to install
Guims
 
Beiträge: 40
Registriert: Mo Sep 02, 2013 5:03 pm

Re: yacy fail nach upgrade mit debian

Beitragvon veto » Do Mai 29, 2014 6:12 am

Orbiter hat geschrieben:Das einzige was tiefgreifend anders ist, ist die Dependency auf Java 7. Das müsste da aber automatisch nachgezogen werden.

Gucke bitte mal was in /var/log/apt/term.log steht


i remove yacy (not purched)
than i auto remove all not used packages
than i install yacy again with apt-get install yacy:
das hier steht im /var/log/apt/term.log :

Log started: 2014-05-29 07:07:49
Selecting previously unselected package sudo.
(Reading database ... 95130 files and directories currently installed.)
Unpacking sudo (from .../sudo_1.8.5p2-1+nmu1_amd64.deb) ...
Selecting previously unselected package yacy.
Unpacking yacy (from .../yacy_1.73.9060_all.deb) ...
Processing triggers for man-db ...
Setting up sudo (1.8.5p2-1+nmu1) ...
Setting up yacy (1.73.9060) ...
Starting YaCy P2P Web Search: failed.
invoke-rc.d: initscript yacy, action "start" failed.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
Log ended: 2014-05-29 07:08:10

das hier ist mein console output:
Preconfiguring packages ...
Selecting previously unselected package sudo.
(Reading database ... 95130 files and directories currently installed.)
Unpacking sudo (from .../sudo_1.8.5p2-1+nmu1_amd64.deb) ...
Selecting previously unselected package yacy.
Unpacking yacy (from .../yacy_1.73.9060_all.deb) ...
Processing triggers for man-db ...
Setting up sudo (1.8.5p2-1+nmu1) ...
Setting up yacy (1.73.9060) ...
Starting YaCy P2P Web Search: failed.
invoke-rc.d: initscript yacy, action "start" failed.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
veto
 
Beiträge: 12
Registriert: So Mai 12, 2013 2:08 am

Re: yacy fail nach upgrade mit debian

Beitragvon veto » Do Mai 29, 2014 6:17 am

just now
apt-get remove --purge yacy
and installed again:


# apt-get remove --purge yacy
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
yacy*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 48.9 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 96885 files and directories currently installed.)
Removing yacy ...
not running.
Purging configuration files for yacy ...


# apt-get install yacy
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
yacy
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/38.0 MB of archives.
After this operation, 48.9 MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package yacy.
(Reading database ... 95190 files and directories currently installed.)
Unpacking yacy (from .../yacy_1.73.9060_all.deb) ...
Setting up yacy (1.73.9060) ...
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/yacy/cora/order/Base64Order : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: net.yacy.cora.order.Base64Order. Program will exit.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
E: Sub-process /usr/bin/dpkg returned an error code (1)




cat /var/log/apt/term.log

Log started: 2014-05-29 07:14:24
Selecting previously unselected package yacy.
(Reading database ... 95190 files and directories currently installed.)
Unpacking yacy (from .../yacy_1.73.9060_all.deb) ...
Setting up yacy (1.73.9060) ...
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/yacy/cora/order/Base64Order : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: net.yacy.cora.order.Base64Order. Program will exit.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
Log ended: 2014-05-29 07:14:42
veto
 
Beiträge: 12
Registriert: So Mai 12, 2013 2:08 am

Re: yacy fail nach upgrade mit debian

Beitragvon Orbiter » Do Mai 29, 2014 9:30 am

"Unsupported major.minor version 51.0"
means that you have an outdated java. apt-get update && apt-get upgrade should fix this. Try also to remove and reinstall java. The latest debian package for YaCy should do that themself but I don't know if this works if a version 51 Java 7 is already preinstalled.
Orbiter
 
Beiträge: 5784
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: yacy fail nach upgrade mit debian

Beitragvon veto » Do Mai 29, 2014 9:51 am

yes i did this, i installed the latest debian java-sdk 7 what comes with a lot of other stuff
than i tried to install yacy again.
same failed result, actually the last error i put.

as i know that debian is quite conservative and carefully with latest updates.
maybe i need to install a not debian revised java packet.
veto
 
Beiträge: 12
Registriert: So Mai 12, 2013 2:08 am

Re: yacy fail nach upgrade mit debian

Beitragvon ban.squidy » So Jun 08, 2014 11:15 am

Ich hatte das selbe Problem, habe aber eine Lösung gefunden.
Bei mir waren openjdk-6 und openjdk-7 parallel installiert!
Nach einem
Code: Alles auswählen
apt-get remove openjdk-6-jre-headless
ging auch die yacy installation ohne Probleme!
ban.squidy
 
Beiträge: 1
Registriert: So Jun 08, 2014 11:09 am

Re: yacy fail nach upgrade mit debian

Beitragvon veto » Mo Jun 09, 2014 5:37 am

ban.squidy hat geschrieben:Ich hatte das selbe Problem, habe aber eine Lösung gefunden.
Bei mir waren openjdk-6 und openjdk-7 parallel installiert!
Nach einem
Code: Alles auswählen
apt-get remove openjdk-6-jre-headless
ging auch die yacy installation ohne Probleme!


yes! this was working:
apt-get remove openjdk-6-jre-headless --purge
apt-get remove openjdk-6-jre --purge
apt-get remove openjdk-6-jdk --purge
apt-get remove yacy --purge


apt-get install openjdk-7-jdk openjdk-7-jre yacy

jetzt laeuft die yacy engine wieder
danke!
veto
 
Beiträge: 12
Registriert: So Mai 12, 2013 2:08 am


Zurück zu Hilfe für Einsteiger und Anwender

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste