Kein Start nach Arbeitsspeichererhöhung

Keine Scheu, hier darf alles gefragt und diskutiert werden. Das ist das Forum für YaCy-Anfänger. Hier kann man 'wo muss man klicken' fragen und sich über Grundlagen zur Suchmaschinentechnik unterhalten.
Forumsregeln
Hier werden Fragen beantwortet und wir versuchen die Probleme von YaCy-Newbies zu klären. Bitte beantwortete Fragen im YaCy-Wiki http://wiki.yacy.de dokumentieren!

Kein Start nach Arbeitsspeichererhöhung

Beitragvon MetaTom » Mo Mär 06, 2017 12:38 pm

Hallo.
Gleiches Problem wie bei Thema :"Zu wenig Arbeitsspeicher!"
Eingetragen in "Memory reserved for JVM" = 2000 MB, dieser Wert lässt sich nicht erhöhen, Yacy stellt von allein diesen Höchstwert ein, wenn ein größerer Wert eingegeben wurde (vorhandener Arbeitsspeicher im System: 16 GB).
Nach Eingabe des höheren Arbeisseichers fordert Yacy Neustart. Aber: Nach herunterfahren von Yacy lässt dieses sich nicht mehr starten. Es passiert einfach nix.
Ergebnis also: Neuinstallation von Yacy. Bisher 3 x getestet mit versch. MB. Das nervt.
Muss ich evtl im Win-System noch eine Arbeitsspeicheranpassung machen?

Danke.

Edit:
Könnte es etwas damit zu tun haben?:
In der startYACY.bat steht:

REM Please change the "javastart" settings in the web-interface "Basic Configuration" -> "Advanced"
set jmx=
set jms=
set javacmd=-Xmx600m -Xms180m <---- das hier, trotz Änderung zuvor im web-interface auf 2000MB.
set priolvl=10
set priority=/BELOWNORMAL
if exist DATA\SETTINGS\httpProxy.conf GoTo :RENAMEINDEX
if exist DATA\SETTINGS\yacy.conf GoTo :GETSTARTOPTS

Danke.

Edit:
Änderung: set javacmd=-Xmx2000m -Xms180m (Wie zuvor im web-interface eingestellt) bringt auch keinen Start des Yacy Servers.
MetaTom
 
Beiträge: 8
Registriert: Sa Mär 04, 2017 11:03 pm

Re: Kein Start nach Arbeitsspeichererhöhung

Beitragvon dk5ras » Mo Mär 06, 2017 3:45 pm

Hatte ich auch; in der config habe ich diese Xmx2000m in Xmx1024m zurückeditiert, waren AFAIR zwei Vorkommen, dann lief wieder alles.

Ralph.
dk5ras
 
Beiträge: 9
Registriert: Fr Dez 02, 2011 7:36 am

Re: Kein Start nach Arbeitsspeichererhöhung

Beitragvon MetaTom » Di Mär 07, 2017 12:45 am

Danke Ralph!

Das hat nach einigem Gesuche funktioniet.
Es waren folgende Dateien und Einträge, die beide auf 1024 geändert wurden:

yacy.conf
Line 10: javastart_Xmx=Xmx1024m

yacy.init
Line 700: javastart_Xmx=Xmx1024m

Danke & Grüsse
MetaTom
 
Beiträge: 8
Registriert: Sa Mär 04, 2017 11:03 pm


Zurück zu Hilfe für Einsteiger und Anwender

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste