Debian 7.8 Yacy setup error Resolved

Discussion in English language.
Forumsregeln
You can start and continue with posts in english language in all other forums as well, but if you are looking for a forum to start a discussion in english, this is the right choice.

Debian 7.8 Yacy setup error Resolved

Beitragvon smokingwheels » Do Apr 02, 2015 2:45 am

Did a apt-get purge yacy as per http://mantis.tokeek.de/view.php?id=339
Did a reinstall eg fresh and it worked fine.

My latest problem on my PC Debian 7.8 fresh install today.
I have added the extra that goes fine but then I had a few errors.
I did a VM yacy install last night was fine.

Second error msg

root@debian:/var# apt-get install yacy
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
yacy
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/39.5 MB of archives.
After this operation, 51.0 MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package yacy.
(Reading database ... 127611 files and directories currently installed.)
Unpacking yacy (from .../yacy_1.83.9118_all.deb) ...
Setting up yacy (1.83.9118) ...
Starting YaCy P2P Web Search: failed.
invoke-rc.d: initscript yacy, action "start" failed.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@debian:/var#

The first error below.

Adding group `yacy' (GID 265) ...
Done.
Adding system user `yacy' (UID 264) ...
Adding new user `yacy' (UID 264) with group `yacy' ...
Not creating home directory `/var/lib/yacy'.
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/yacy/cora/order/Base64Order : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: net.yacy.cora.order.Base64Order. Program will exit.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@debian:/var#

What am I doing wrong?
smokingwheels
 
Beiträge: 130
Registriert: Sa Aug 31, 2013 7:16 am

Zurück zu English

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast