raspberry pi, no start

Discussion in English language.
Forumsregeln
You can start and continue with posts in english language in all other forums as well, but if you are looking for a forum to start a discussion in english, this is the right choice.

raspberry pi, no start

Beitragvon metoo » Mi Okt 05, 2016 9:16 pm

I am trying to get yacy running on a spare raspberry pi I had.
I have followed the instructions here:
http://www.yacy-websearch.net/wiki/inde ... spberry_Pi
But it seems yacy isn't running. I can ssh to the raspberry pi and run the startYACY.sh.
I even get the message that I can reach yacy via web

>> YaCy started as daemon process. Administration at http://localhost:8090 <<

Substituting localhost for ip of the raspberry pi, the page is unreachable.
Running top on the raspberry pi doesn't show yacy as a running process.

I haven't found any logs for yacy,
Does anyone have any ideas where I should look? or what might be the problem?
metoo
 
Beiträge: 5
Registriert: Mi Okt 05, 2016 9:07 pm

Re: raspberry pi, no start

Beitragvon metoo » Mi Okt 05, 2016 9:22 pm

java -version shows 1.8.0_101-b13
and I am using the most current yacy package from http://yacy.net/en/ 1.90
metoo
 
Beiträge: 5
Registriert: Mi Okt 05, 2016 9:07 pm

Re: raspberry pi, no start

Beitragvon metoo » Do Okt 06, 2016 12:09 am

netstat | grep 8090
returns nothing. It sure seems like yacy is not running.

/home/pi/yacy/startYACY.sh
doesn't return any errors, and even says yacy has been started.
I still haven't figured out what is going on.
metoo
 
Beiträge: 5
Registriert: Mi Okt 05, 2016 9:07 pm

Re: raspberry pi, no start

Beitragvon luc » Do Okt 06, 2016 6:49 am

Hello metoo,
you can try to start YaCy in "debug" mode using -d option : startYACY.sh -d

In this mode it will not be launched as a background daemon process. It can be helpful because doing so you will immediately see log messages appearing in your console.

Best regards,
Luc
luc
 
Beiträge: 232
Registriert: Mi Aug 26, 2015 1:04 am

Re: raspberry pi, no start

Beitragvon metoo » Do Okt 06, 2016 2:46 pm

Thank you for the tip. I have used that command and get the following error.

Error occurred during initialization of VM
Server VM is only supported on ARMv7+ VFP

So there seems to be a problem with java.
Does anyone know what might be going on here?

Why wouldn't yacy give an error when launched?
metoo
 
Beiträge: 5
Registriert: Mi Okt 05, 2016 9:07 pm

Re: raspberry pi, no start

Beitragvon luc » Do Okt 06, 2016 6:43 pm

It looks like the JVM you installed does not work with your processor architecture... Is it a Raspberry version 1, which is ARMv6 according to Wikipedia?

Maybe you can try with the other JVM version provided by Oracle... Or with the java package provided with your distribution?

By the way, I think the error is not logged by YaCy because it occurs too early and the JVM isn't even initialized.
luc
 
Beiträge: 232
Registriert: Mi Aug 26, 2015 1:04 am

Re: raspberry pi, no start

Beitragvon metoo » Do Okt 06, 2016 8:33 pm

Using openJDK, but it's very slow. I can get to the web interface.
I think I will just test yacy for awhile to see if I want to dedicate more hardware, because currently it is unusably slow.

Thanks for the tips in getting me up and running.
metoo
 
Beiträge: 5
Registriert: Mi Okt 05, 2016 9:07 pm


Zurück zu English

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron