YaCy startet nicht mehr nach update auf 4719

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

YaCy startet nicht mehr nach update auf 4719

Beitragvon kiney » Mo Apr 21, 2008 12:36 pm

Moin,

ich brauch schon wieder eure Hilfe... ich hab YaCy auf 4719 upgedated.
Jetzt startet es nicht mehr sondern spuckt folgende Meldung aus:
Code: Alles auswählen
E 2008/04/21 13:32:45 STARTUP FATAL ERROR: null
java.lang.NegativeArraySizeException
        at de.anomic.kelondro.kelondroRowSet.importRowSet(kelondroRowSet.java:86)
        at de.anomic.index.indexContainerHeap$heapFileEntries.next0(indexContainerHeap.java:251)
        at de.anomic.index.indexContainerHeap$heapFileEntries.next(indexContainerHeap.java:259)
        at de.anomic.index.indexContainerHeap$heapFileEntries.next(indexContainerHeap.java:230)
        at de.anomic.index.indexContainerHeap.initWriteMode(indexContainerHeap.java:121)
        at de.anomic.index.indexRAMRI.<init>(indexRAMRI.java:83)
        at de.anomic.plasma.plasmaWordIndex.<init>(plasmaWordIndex.java:102)
        at de.anomic.plasma.plasmaSwitchboard.<init>(plasmaSwitchboard.java:975)
        at yacy.startup(yacy.java:234)
        at yacy.main(yacy.java:994)


ein java-prozess läuft weiter, beansprucht aber quasi 0 cpu-zeit. Und YaCy startet nicht.
kiney
 
Beiträge: 14
Registriert: Di Apr 08, 2008 10:11 pm

Re: YaCy startet nicht mehr nach update auf 4719

Beitragvon miTreD » Mo Apr 21, 2008 2:02 pm

Ich würde den Index mal neu erstellen, da hat die letzten Tage häufiger Probleme gelöst.
- YaCy beenden
- yacy/DATA/INDEX/freeworld/TEXT/RICOLLECTION/collection.index löschen
- YaCy starten
Kann jetzt was dauern.
miTreD
 
Beiträge: 1241
Registriert: Mi Jun 27, 2007 11:35 am
Wohnort: /home

Re: YaCy startet nicht mehr nach update auf 4719

Beitragvon kiney » Mo Apr 21, 2008 5:15 pm

gleiche Fehlermeldung.
kiney
 
Beiträge: 14
Registriert: Di Apr 08, 2008 10:11 pm

Re: YaCy startet nicht mehr nach update auf 4719

Beitragvon kiney » Do Apr 24, 2008 8:33 pm

leider habe ich mein yacy immernoch nicht wieder zum laufen bekommen. Wie kann man yacy ohne benutzung des webinterface up- bzw. downgraden? einfach ein andere drüberentpacken?
kiney
 
Beiträge: 14
Registriert: Di Apr 08, 2008 10:11 pm

Re: YaCy startet nicht mehr nach update auf 4719

Beitragvon Orbiter » Do Apr 24, 2008 8:47 pm

genau, wenn dein yacy-Homeverzeichnis 'yacy' heisst, dann einfach das Release ins übergeordnete Verzeichnis legen, und dort
tar xfz <release-file>
machen. Das bappt dann einfach das neue Zeug über das alte und das ist auch das was der Auto-Updater macht.
Orbiter
 
Beiträge: 5798
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: YaCy startet nicht mehr nach update auf 4719

Beitragvon miTreD » Fr Apr 25, 2008 8:14 am

kiney hat geschrieben:leider habe ich mein yacy immernoch nicht wieder zum laufen bekommen.
Kannst Du vor dem Downgrade YaCy bitte mal mit dem Parameter -d starten? das aktiviert den Debug-Modus. Vielleicht sehen wir dann etwas genauer wo es klemmt.
miTreD
 
Beiträge: 1241
Registriert: Mi Jun 27, 2007 11:35 am
Wohnort: /home


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast