Kein Zugriff auf Admin-Oberfläche (BRUTE-FORCE PREVENTION)

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

Kein Zugriff auf Admin-Oberfläche (BRUTE-FORCE PREVENTION)

Beitragvon AllesMeins » Do Jan 29, 2009 5:27 pm

Hi,

es kommt immer wieder vor, dass ich keinen Zugriff auf die Yacy-Oberfläche bekomme. Im Logfile findet sich dann soetwas wie:

PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 1065

Erst mal scheint es mir doch seltsam von localhost ein brute-force zu erwarten und zum anderen ist das nette "slowing down" unterm Strich ein "Browser zeigt sehr lange loading und gibt dann auf". Wie kommt das zur stande? Vor allem, weil ich zum Beispiel eben zwei Stunde weg war und sicher nicht auf yacy zugegriffen habe. Wieso also wertet er mir dann bereits meinen ersten Zugriffsversuch als "Brute Force Versuch"?

Nachtrag: Eben habe ich sogar ein "PLASMA ACCESS FROM localhost DENIED" im Log bekommen.
AllesMeins
 
Beiträge: 28
Registriert: So Jun 29, 2008 1:42 am

Re: Kein Zugriff auf Admin-Oberfläche

Beitragvon Orbiter » Do Jan 29, 2009 5:29 pm

hast du ein Passwort gesetzt und ggf. geändert? Dann einen anderen Browser genommen?
Manche Browser speichern ja die Passwörter, und schicken die dann unaufgefordert, ggf. dann den falschen immer wieder.
Bitte mal versuchen alle Browser zu schliessen und wieder neu zu öffnen, und YaCy neu starten.
Orbiter
 
Beiträge: 5797
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: Kein Zugriff auf Admin-Oberfläche (BRUTE-FORCE PREVENTION)

Beitragvon AllesMeins » Do Jan 29, 2009 11:56 pm

Ne, habe kein Passwort gesetzt oder dergleichen. Allerdings hatte ich ein komisches Phänomen, dass ich auf einen Link hier im Wiki geklickt habe, der auf localhost:8080/irgendwas verweist und da bin ich aufgefordert worden ein Passwort enzugeben. Da ich das nicht wusste habe ich auf "Abbrechen" geklickt und die Adresse nochmal manuell eingegeben und kam dann problemlos auf die Seite ohne, dass ein Passwort verlangt wurde. Das war allerdings auch schon 3 Stunden bevor dem Problem jetzt. Zwischenzeitlich war der Browser auch mehrfach schon zu.
Ich habe dann yacy neu gestartet (auch das stellte sich als schwierig heraus, dass das yacyInit-Script nicht freundlich beenden konnte, sondern nach 10 Minuten gekillt hat) und danach funktioniert wieder alles einwandfrei.
AllesMeins
 
Beiträge: 28
Registriert: So Jun 29, 2008 1:42 am

Re: Kein Zugriff auf Admin-Oberfläche (BRUTE-FORCE PREVENTION)

Beitragvon Lotus » Sa Jan 31, 2009 6:06 pm

AllesMeins hat geschrieben:Ne, habe kein Passwort gesetzt oder dergleichen. Allerdings hatte ich ein komisches Phänomen, dass ich auf einen Link hier im Wiki geklickt habe, der auf localhost:8080/irgendwas verweist und da bin ich aufgefordert worden ein Passwort enzugeben. Da ich das nicht wusste habe ich auf "Abbrechen" geklickt und die Adresse nochmal manuell eingegeben und kam dann problemlos auf die Seite ohne, dass ein Passwort verlangt wurde.

Das ist ein Sicherheitsfeature, das verhindert, dass jemand die Konfiguration durch Iframes oder Bilder in dritten Seiten ändern kann.
Dazu wird der Referer ausgewertet.
Mir fällt dazu gerade keine andere Lösung ein. Ein Zulassen nach einem Klick auf Abbrechen käme einem erfolgreichen Angriff gleich.
Lotus
 
Beiträge: 1699
Registriert: Mi Jun 27, 2007 3:33 pm
Wohnort: Hamburg

Re: Kein Zugriff auf Admin-Oberfläche (BRUTE-FORCE PREVENTION)

Beitragvon papyrus » Di Mär 31, 2009 4:05 pm

Hallo YaCy-Forum
Das von AllesMeins beschriebene Problem existiert auch auf meinem System. Ich konnte den Fehler reproduzieren und auf einen Browser eingrenzen. Von den getesteten Browsern: Firefox, Konqueror, Opera und Internet Explorer löste nur Firefox das Problem aus. Folgende Schritte sind nötig:

1. ./startYACY.sh # Die Seite http://localhost:8080/Status.html wird im Firefox geladen.
2. Einen weiteren Tab öffnen und eine externe Seite laden die einen Link auf die lokale YaCy Instanz enthält (bspw. diese Formseite). Diesen Link anklicken.
3. Firefox Dialog "Authentifizierung erforderlich" wird angezeigt. "OK" wählen. Der Firefox Dialog "Authentifizierung erforderlich" wird erneut angezeigt. Danach "Abbrechen" wählen. Eine leere Seite wird im Firefox angezeigt. (Der Fehler tritt nicht ein, wenn direkt "Abbrechen" gewählt wird!)
4. Auf der Seite im ersten Tab, die zuvor geladen wurde, zirka 10-20 mal auf "Crawl Start & Monitoring" klicken. Danach werden alle Anfragen von localhost ignoriert und YaCy kann somit nicht mehr "sauber" beendet werden.

Anfrage über die lokale LAN IP werden weiterhin beantworten. Wenn jedoch kein Passwort gesetzt wurde erhält man dennoch keinen Zugriff auf die Adminbefehle. Das Problem konnte ich im Firefox durch öffnen von nicht "Crawl Start & Monitoring" Links nicht reproduzieren. Dass heisst andere geschützte Bereiche lösen "BRUTE-FORCE PREVENTION" in diesem Fall nicht aus. Deshalb gehe ich davon aus, dass auch die Seite "Crawl Start & Monitoring" angepasst werden kann ohne das sie den Fehler im Firefox auslöst.


cat DATA/LOG/yacy00.log | grep ACCESS
W 2009/03/31 13:13:08 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 2
W 2009/03/31 13:13:53 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 3
W 2009/03/31 13:13:53 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 4
W 2009/03/31 13:13:55 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 5
W 2009/03/31 13:13:55 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 6
W 2009/03/31 13:13:58 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 7
W 2009/03/31 13:13:58 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 8
W 2009/03/31 13:13:58 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 9
W 2009/03/31 13:14:01 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 10
W 2009/03/31 13:14:01 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:02 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 11
W 2009/03/31 13:14:02 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:02 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 12
W 2009/03/31 13:14:02 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:02 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 13
W 2009/03/31 13:14:02 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:02 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 14
W 2009/03/31 13:14:02 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:03 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 15
W 2009/03/31 13:14:03 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:03 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 16
W 2009/03/31 13:14:03 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:03 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 17
W 2009/03/31 13:14:03 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:04 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 18
W 2009/03/31 13:14:04 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:04 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 19
W 2009/03/31 13:14:04 PLASMA ACCESS FROM localhost DENIED
W 2009/03/31 13:14:04 PLASMA SLOWING DOWN ACCESS FOR BRUTE-FORCE PREVENTION FROM localhost, ATTEMPT 20
W 2009/03/31 13:14:04 PLASMA ACCESS FROM localhost DENIED


LINUX

yacy_v0.7_20090121_5494.tar.gz

uname -mrspv
Linux 2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 i686 i686

firefox -version
Mozilla Firefox 3.0.8, Copyright (c) 1998 - 2009 mozilla.org

java -version
java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) Server VM (build 11.2-b01, mixed mode)

opera -version
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
Opera 9.64. Build 2480 for Linux. Qt library 3.3.8b.

konqueror -version
Qt: 4.4.3
KDE: 4.2.1 (KDE 4.2.1)
Konqueror: 4.2.1 (KDE 4.2.1)


WINDOWS

yacy_v0.7_20090114_5495.exe

java -version
java version "1.6.0_11"
Java(TM) SE Runtime Environment (build 1.6.0_11-b03)
Java HotSpot(TM) Client VM (build 11.0-b16, mixed mode, sharing)

Windows 2000 5.00.2195 Service Pack 4
Internet Explorer Version 6.0.2800.1106
papyrus
 
Beiträge: 4
Registriert: Di Mär 31, 2009 3:48 pm

Re: Kein Zugriff auf Admin-Oberfläche (BRUTE-FORCE PREVENTION)

Beitragvon papyrus » Di Mär 31, 2009 4:16 pm

Ein Link auf den geschützten Bereich der lokalen YaCy Instanz.

http://localhost:8080/WatchCrawler_p.html?autoforward=
papyrus
 
Beiträge: 4
Registriert: Di Mär 31, 2009 3:48 pm


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast