Fehlermeldungen im ServerLog

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

Fehlermeldungen im ServerLog

Beitragvon Yua » Mo Mär 09, 2009 12:26 am

Ich erhalte massenweise Fehlermeldungen dieser Art:

W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.sei.cmu.edu/about/' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.sei.cmu.edu/productlines/plp_init.html' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.sei.cmu.edu/cmmi/' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.sei.cmu.edu/about/bov/' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.securityspace.com/s_survey/data/man.200702/apachemods.html' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.securityspace.com/s_survey/data/man.200702/p3p.html' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 00:12:37 STACKCRAWL URL 'http://www.securityspace.com/s_survey/data/man.200702/httpbyip.html' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt

Soweit ich das verstehe, handelt es sich um einen Konflikt, der mit der YaCy-Konfiguration zusammen hängt. Was ich nicht verstehe ist, warum das jetzt plötzlich auftritt und was ich dagegen tun muss. Kann jemand helfen?
Yua
 
Beiträge: 21
Registriert: Mo Jan 19, 2009 7:33 pm

Re: Fehlermeldungen im ServerLog

Beitragvon Orbiter » Mo Mär 09, 2009 12:48 am

hab ich noch nie gesehen. hast du irgendwas besonderes gemacht?
Orbiter
 
Beiträge: 5797
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: Fehlermeldungen im ServerLog

Beitragvon Yua » Mo Mär 09, 2009 1:13 am

Ich habe nach einer Neuinstallation des Systems YaCy installiert und den zuvor gesicherten Ordner DATA zurück kopiert. Den Proxy (localhost:8080) habe ich im Browser erst heute wieder aktiviert. YaCy ist also ein paar Tage nicht als Proxy gelaufen. Seit der vom Proxy initiierte Crawl läuft, tauchen diese Meldungen seitenweise auf. YaCy scheint aber ansonsten normal zu funktionieren. Die Warnmeldungen haben weiterhin den schon geposteten Inhalt:

W 2009/03/09 01:06:27 STACKCRAWL URL 'http://www.bsi.bund.de/fachthem/egov/7.htm' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 01:06:27 STACKCRAWL URL 'http://www.bsi.bund.de/aktuell/' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 01:06:27 STACKCRAWL URL 'http://www.bsi.bund.de/fachthem/egov/mailto:bsi%40bsi.bund.de' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt
W 2009/03/09 01:06:27 STACKCRAWL URL 'http://www.bsi.bund.de/fachthem/egov/7.htm' has conflicting initiator properties: global = true, proxy = true, initiator = ------------, profile.handle = vnJvP-96fbgt

Ich werde mal auf dev. 072/5682 updaten und dann schauen, ob sich was ändert.
Yua
 
Beiträge: 21
Registriert: Mo Jan 19, 2009 7:33 pm

Re: Fehlermeldungen im ServerLog

Beitragvon Orbiter » Mo Mär 09, 2009 1:24 am

lösch doch mal DATA/INDEX/freeworld/QUEUES/crawlProfiles*
vorsicht: deine crawl queues sind dann weg.
Orbiter
 
Beiträge: 5797
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: Fehlermeldungen im ServerLog

Beitragvon Yua » Mo Mär 09, 2009 9:01 am

Das Update hat erwartungsgemäß nichts gebracht. Ich habe den recht umfangreichen Crawl einfach über Stunden weiter laufen lassen, ohne die crawlProfiles* zu löschen. Mittlerweile werden, soweit ich das beurteilen kann, nur noch die Eintragungen im Crawler-Puffer abgearbeitet (lokal und als Remote Crawl) sowie der RWI gefüllt. Und die Warnmeldungen sind verschwunden. Das Problem war also keins, was die Funktionalität von YaCy erkennbar beeinträchtigt hat. Es sollte irgendwie mit dem Einlesen der URL's aus dem Netz zu tun gehabt haben. (Wenn ich doch bloß ein wenig mehr Ahnung hätte!! :roll: ) Ich hab' den Proxy erst mal wieder deaktiviert. Soll ich die Sache im Auge behalten oder unter der Rubrik "kann ja mal passieren" abhaken?
Yua
 
Beiträge: 21
Registriert: Mo Jan 19, 2009 7:33 pm


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron