apache2 sendet sig als application/x-tar

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

apache2 sendet sig als application/x-tar

Beitragvon Orbiter » Mo Mai 11, 2009 11:24 pm

Mein Apache kann die neuen Signature-Files nicht mit einem richigen mime-type versehen.
Code: Alles auswählen
telnet latest.yacy.de 80
Trying 81.169.145.65...
Connected to latest.yacy.de.
Escape character is '^]'.
GET /yacy_v0.77_20090428_5895.tar.gz.sig HTTP/1.1
Host: latest.yacy.de

HTTP/1.1 200 OK
Date: Mon, 11 May 2009 22:20:24 GMT
Server: Apache/2.0.54 (Debian GNU/Linux) mod_jk2/2.0.4 mod_perl/1.999.21 Perl/v5.8.4
Last-Modified: Mon, 27 Apr 2009 22:30:48 GMT
ETag: "1788042-40-e5deb600"
Accept-Ranges: bytes
Content-Length: 64
Content-Type: application/x-tar
Content-Encoding: gzip
X-Cache: MISS from latest.yacy.de

MCwCFCr8EHvaNnMsJWYniQAhibNtbFzlAhRSY9k5bDTEwFhUEBg1n8O8jw2itw==Connection closed by foreign host.

Ich hab schon alles im Apache abgesucht, aber kann nicht herausfinden was ich ändern muss damit das Apache richtig macht. Kennt sich da einer aus?
Orbiter
 
Beiträge: 5799
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: apache2 sendet sig als application/x-tar

Beitragvon Lotus » Di Mai 12, 2009 6:42 am

Geht über eine .htaccess im entsprechenden Verzeichnis.
z.B.
Code: Alles auswählen
<Files "xyz.txt" >
ForceType application/octet-stream
</Files>

Ich glaube da gehen auch Wildcards.
Lotus
 
Beiträge: 1699
Registriert: Mi Jun 27, 2007 3:33 pm
Wohnort: Hamburg

Re: apache2 sendet sig als application/x-tar

Beitragvon Orbiter » Di Mai 12, 2009 10:32 pm

ich hab jetzt nach vielem Rumprobieren folgendes in der .htaccess stehen:
Code: Alles auswählen
AddType application/octet-stream .sig
RemoveEncoding .sig

Hatte erst keine Auswirkungen, bis ich aus
https://help.ubuntu.com/community/Enabl ... ccessFiles
erfahren habe das man erst das
"AllowOverride None"
in
/etc/apache2/sites-available/default
zu
"AllowOverride All"
setzten muss. Danach hatte ich folgendes Ergebnis:
Code: Alles auswählen
Content-Type: application/octet-stream
Content-Encoding: gzip

D.h. die "AddType application/octet-stream .sig" hat funktioniert, apache2 sendet das aber immer noch als gzip was unser apache httpc gleich nutzt um das ganze zu dekomprimieren was falsch ist. Hat noch jemand eine Idee, wie man das "Content-Encoding: gzip" weg bekommt?
Orbiter
 
Beiträge: 5799
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: apache2 sendet sig als application/x-tar

Beitragvon flori » Di Mai 12, 2009 10:49 pm

flori
 
Beiträge: 245
Registriert: Mi Jun 27, 2007 10:17 pm
Wohnort: Karlsruhe

Re: apache2 sendet sig als application/x-tar

Beitragvon Orbiter » Di Mai 12, 2009 10:59 pm

ja, da war ich auch schon, ohne das es geholfen hat. Hab jetzt
Code: Alles auswählen
AddEncoding gzip .gz
AddType application/octet-stream .sig
<Files *.sig>
  RemoveEncoding .gz
</Files>

mit gleichem Ergebnis wie oben
Orbiter
 
Beiträge: 5799
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: apache2 sendet sig als application/x-tar

Beitragvon protocols » Mi Mai 13, 2009 10:36 am

evtl. sind andere module dafür verantwortlich, wie z.B. mod_deflate.. aber kommt halt stark darauf an was du alles aktiviert hast und deine config genau aussieht.
protocols
 
Beiträge: 15
Registriert: Sa Mai 09, 2009 5:25 pm

Re: apache2 sendet sig als application/x-tar

Beitragvon Orbiter » Mi Mai 13, 2009 10:55 am

ich hab an der Konfiguration gar nichts geändert, das ist einfach die Standardinstallation die man mir auf meinen vServer gemacht hat.
Orbiter
 
Beiträge: 5799
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: apache2 sendet sig als application/x-tar

Beitragvon flori » Mi Mai 13, 2009 11:22 am

Schau mal in /etc/apache2/mods-enabled/mime.conf
Bei mir ist
#AddEncoding x-gzip .gz .tgz
auskommentiert.

Und schau mal mit
grep gz -r /etc/apache2/
was alles an gz-Dateien konfiguriert ist.
flori
 
Beiträge: 245
Registriert: Mi Jun 27, 2007 10:17 pm
Wohnort: Karlsruhe

Re: apache2 sendet sig als application/x-tar

Beitragvon Orbiter » Mi Mai 13, 2009 11:28 am

flori hat geschrieben:Schau mal in /etc/apache2/mods-enabled/mime.conf
Bei mir ist
#AddEncoding x-gzip .gz .tgz
auskommentiert.

ich hab die Datei gar nicht. Zu mime habe ich nur folgendes:
Code: Alles auswählen
/etc/apache2# ls -lR | grep mime
-rw-r--r--  1 root root   90 Sep  5  2005 mime_magic.conf
-rw-r--r--  1 root root   72 Sep  5  2005 mime_magic.load


flori hat geschrieben:Und schau mal mit
grep gz -r /etc/apache2/
was alles an gz-Dateien konfiguriert ist.

Code: Alles auswählen
grep gz -r /etc/apache2/
/etc/apache2/magic:# compress, gzip, pack, compact, huf, squeeze, crunch, freeze, yabba, whap, etc.
/etc/apache2/magic:# gzip (GNU zip, not to be confused with [Info-ZIP/PKWARE] zip archiver)
/etc/apache2/magic:0       string          \037\213        application/octet-stream     x-gzip
/etc/apache2/magic:# According to gzip.h, this is the correct byte order for packed data.
/etc/apache2/magic:#0   string          \037\236        Frozen file 1.0 (or gzip 0.5)
/etc/apache2/apache2.conf:AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip
/etc/apache2/apache2.conf:AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
/etc/apache2/apache2.conf:AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
/etc/apache2/apache2.conf:AddEncoding x-gzip gz tgz
/etc/apache2/apache2.conf:AddType application/x-tar .tgz
Orbiter
 
Beiträge: 5799
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: apache2 sendet sig als application/x-tar

Beitragvon flori » Mi Mai 13, 2009 12:19 pm

Die relevanten Stellen von /etc/apache2/mods-enabled/mime.conf sehen bei mir so aus:
Code: Alles auswählen
# AddType allows you to add to or override the MIME configuration
# file mime.types for specific file types.
#
#AddType application/x-gzip .tgz
#
# AddEncoding allows you to have certain browsers uncompress
# information on the fly. Note: Not all browsers support this.
# Despite the name similarity, the following Add* directives have
# nothing to do with the FancyIndexing customization directives above.
#
#AddEncoding x-compress .Z
#AddEncoding x-gzip .gz .tgz
#AddEncoding x-bzip2 .bz2
#
# If the AddEncoding directives above are commented-out, then you
# probably should define those extensions to indicate media types:
#
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz
AddType application/x-bzip2 .bz2

Bei dir ist alles in /etc/apache2/apache2.conf. Du kannst das ja mal übernehmen und schauen was passiert.
flori
 
Beiträge: 245
Registriert: Mi Jun 27, 2007 10:17 pm
Wohnort: Karlsruhe


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron