Fehler im Debian-Initskript

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

Fehler im Debian-Initskript

Beitragvon cfr34x » Mo Okt 19, 2009 4:28 pm

Hallo zusammen!

Durch das Refactoring in letzter Zeit hat sich ein Fehler im Debian-Initskript eingeschlichen, wodurch sich YaCy nicht mehr starten lässt.

Hab's geschafft, das hier zu beheben, deshalb hier der Diff ("rechts" ist die neue Version):

Code: Alles auswählen
124c124
<       ARGS="$JAVA_ARGS -classpath $CLASSPATH yacy"
---
>       ARGS="$JAVA_ARGS -classpath $CLASSPATH net.yacy.yacy"
149c149
<               cmdline="$JAVA $JAVA_ARGS -cp $CLASSPATH yacy -shutdown"
---
>               cmdline="$JAVA $JAVA_ARGS -cp $CLASSPATH net.yacy.yacy -shutdown"


Wäre schön, wenn das jemand im SVN ändern könnte.

Viele Grüße
cfr34x
cfr34x
 
Beiträge: 49
Registriert: Sa Jan 31, 2009 6:24 pm

Re: Fehler im Debian-Initskript

Beitragvon Lotus » Mo Okt 19, 2009 6:06 pm

svn 6430
ungetestet,
bitte gucken ob an noch mehr stellen der classpath geändert werden muss.
Lotus
 
Beiträge: 1699
Registriert: Mi Jun 27, 2007 3:33 pm
Wohnort: Hamburg

Re: Fehler im Debian-Initskript

Beitragvon Orbiter » Mo Okt 19, 2009 6:56 pm

ohje isch bitte um Entschuldigung, das hatte ich übersehen. ich hatte schon vermutet dass es bei Start-Up Scripten Probleme geben könnte, aber das hier nicht gefunden. danke Lotus!
Orbiter
 
Beiträge: 5797
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron