oops, just got this error.

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

oops, just got this error.

Beitragvon nstaudt » Sa Sep 25, 2010 2:37 pm

Everything else seems ok, I just get this error when I click on the "System Update" link.


request: GET http://localpeer/ConfigUpdate_p.html

500 Internal Server Error

Unexpected error while processing query.
Session: Session_88.107.59.181:55181#0
Query: /ConfigUpdate_p.html
Client: 88.107.59.181
Reason: null

Exception occured: java.lang.reflect.InvocationTargetException

TRACE:
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at de.anomic.http.server.HTTPDFileHandler.invokeServlet(HTTPDFileHandler.java:1182)
at de.anomic.http.server.HTTPDFileHandler.doResponse(HTTPDFileHandler.java:772)
at de.anomic.http.server.HTTPDFileHandler.doGet(HTTPDFileHandler.java:230)
at de.anomic.http.server.HTTPDemon.GET(HTTPDemon.java:407)
at sun.reflect.GeneratedMethodAccessor30.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at de.anomic.server.serverCore$Session.listen(serverCore.java:731)
at de.anomic.server.serverCore$Session.run(serverCore.java:630)
Caused by: java.lang.IllegalArgumentException: Null charset name
at java.nio.charset.Charset.lookup(Unknown Source)
at java.nio.charset.Charset.forName(Unknown Source)
at net.yacy.document.parser.htmlParser.parseToScraper(htmlParser.java:99)
at net.yacy.repository.LoaderDispatcher.parseResource(LoaderDispatcher.java:330)
at de.anomic.yacy.yacyRelease.allReleaseFrom(yacyRelease.java:237)
at de.anomic.yacy.yacyRelease.getReleases(yacyRelease.java:219)
at de.anomic.yacy.yacyRelease.allReleases(yacyRelease.java:196)
at ConfigUpdate_p.respond(ConfigUpdate_p.java:198)
... 13 more
Generated Sat, 25 Sep 2010 13:34:48 +0000 by abbot.yacy
nstaudt
 
Beiträge: 73
Registriert: Fr Aug 13, 2010 10:54 am

Re: oops, just got this error.

Beitragvon flori » Sa Sep 25, 2010 4:07 pm

fix in 7185, please try
flori
 
Beiträge: 245
Registriert: Mi Jun 27, 2007 10:17 pm
Wohnort: Karlsruhe

Re: oops, just got this error.

Beitragvon nstaudt » Sa Sep 25, 2010 5:44 pm

will do when i get home tomorrow. nice work, thanks! :D
nstaudt
 
Beiträge: 73
Registriert: Fr Aug 13, 2010 10:54 am

Re: oops, just got this error.

Beitragvon Copro » Sa Sep 25, 2010 5:59 pm

SVN 7185 fixed the problem in my case as well ;-)

You can either downgraded by uninstalling YaCy and keeping your settings and then using the update mechanism to install 7185 or higher oder directly extract a newer build from one of the build locations over the YaCy install directory while YaCy is not running. (e.g. hxxp://www.yacystats.de/yacybuild/)

Update http://localhost:8080/ConfigUpdate_p.html funzt wieder mit der neuen 7185 Version.
Copro
 
Beiträge: 207
Registriert: Do Dez 13, 2007 3:37 am


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste