Indizieren meiner Homepage geht nicht

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

Indizieren meiner Homepage geht nicht

Beitragvon rm42195 » So Nov 28, 2010 12:48 pm

Ich habe einen vServer und auf diesem mehrere Domains, mit natürlich der gleichen IP.

Wenn ich nun die 2. Homepage indizieren möchte klappt dies nicht weil es die gleiche IP hat und lokale Domains nicht indiziert werden können.

Schalte ich aber von "Community-based web search" auf "Intranet Indexing" um, geht es nicht, weil meine andere Domain eine Adresse aus dem Wörld Weit Web ist :-(

Wie kann man eine Seite indizieren welche einen anderen Namen hat, aber "zufälligerweise" die gleiche IP?
rm42195
 
Beiträge: 3
Registriert: So Nov 28, 2010 12:35 pm

Re: Indizieren meiner Homepage geht nicht

Beitragvon Quix0r » Sa Jan 22, 2011 12:19 pm

Was sind deine Einstellungen, die zu diesem Fehler fuehren? Leider haben hier die Devs keine Glaskugel zu Hause stehen, die ihnen sagt, welche Einstellungen du hast. ;) Und poste bitte auch mal etwas releavantes aus DATA/LOG/yacy00.log, z.B. dann wo du den Crawl gestartet hast, der funktionierte und von dem der nicht funktionierte.
Quix0r
 
Beiträge: 1345
Registriert: Di Jul 31, 2007 9:22 am
Wohnort: Krefeld

Re: Indizieren meiner Homepage geht nicht

Beitragvon cfr34x » Fr Jan 28, 2011 5:36 pm

Hallo zusammen,

ich wollte gerade einen Thread zu genau dem gleichen Thema erstellen, da hab ich diesen hier gesehen.

Mein Peer ist auf den Webportal-Modus gestellt, da er nur Seiten von meinem VServer indizieren soll.
YaCy läuft allerdings auch auf dem VServer und hat somit die gleiche (externe) IP.

Wenn ich jetzt eine beliebige Seite auf dem VServer als Crawl-Start eingebe, erhalte ich folgende Meldung und nichts weiter passiert:
Crawling von "http://www.example.com" schlug fehl. Grund: denied_(the host 'www.example.com' is local, but local addresses are not accepted: 78.111.xxx.xxx)


Kann man hier vielleicht eine Ausnahme eintragen, dass die eigene externe Adresse erlaubt wird?

Viele Grüße
Thomas
cfr34x
 
Beiträge: 49
Registriert: Sa Jan 31, 2009 6:24 pm

Re: Indizieren meiner Homepage geht nicht

Beitragvon Orbiter » Fr Jan 28, 2011 6:20 pm

für solche Fälle gibts noch die 'allip'-Einstellungen, und ich überlege schon ob man die Intranet/Portal-Netzeinstellungen weg machen und statt dessen gleich die allip anbieten sollte.

so vorgehen:
/ConfigNetwork_p.html aufrufen
bei 'Network Definition' defaults/yacy.network.allip.unit auswählen
'Change Network' drücken.

schon sollte es keine IP-Sperre mehr geben. Ist dann aber natürlich ein neuer, leerer Index.
Orbiter
 
Beiträge: 5796
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 3 Gäste

cron