Problem bei meiner Webseite?

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

Problem bei meiner Webseite?

Beitragvon bbtuxi » Mo Mai 30, 2011 7:28 pm

Problem beim Crawlen meiner Webseite:

I 2011/05/30 20:25:44 Rejected URL http://burningboard.net/ - redirection to dou
ble content (http return code = 307)


Kann mir jemand sagen was das bedeutet? Warum crawlt Yacy meine Seite nicht?

grüße


Liegt das an der Weiterleitung? Ich leite alle www Adressen auf mit ohne um:)

grüße
bbtuxi
 
Beiträge: 50
Registriert: Fr Jan 16, 2009 10:28 pm

Re: Problem bei meiner Webseite?

Beitragvon bbtuxi » Mo Mai 30, 2011 7:39 pm

Den Code in meiner HtAccess Datei lautet:

Das sollte doch einer 301er Weiterleitung sein und Yacy müßte das so schlucken? Was mache ich Falsch? Hab leider nicht soviel Ahnung von dem kram....

Code: Alles auswählen
RewriteCond %{HTTP_HOST} ^www.burningboard.net$ [NC]
RewriteRule ^(.*) http://burningboard.net/$1 [L,R=301]




# WCF-SEO-START
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /

RewriteRule ^tag/([0-9]+)-([^/\.]*)/?$ index.php?page=TaggedObjects&tagID=$1 [L,QSA]
RewriteRule ^user/([0-9]+)-([^/\.]*)/?$ index.php?page=User&userID=$1&username=$2 [L,QSA]
RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/last-post\.html$ index.php?page=Thread&threadID=$2&action=lastPost [L,QSA]
RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/first-new-post\.html$ index.php?page=Thread&threadID=$2&action=firstNew [L,QSA]
RewriteRule ^([^/\.]+)/p([0-9]+)-([^/\.]*)/?$ index.php?page=Thread&postID=$2 [L,QSA]
RewriteRule ^board([0-9]+)-([^/\.]+)/([0-9]+)-([^/\.]*)/index([0-9]+)\.html$ index.php?page=Thread&threadID=$3&pageNo=$5 [L,QSA]
RewriteRule ^([^/\.]+)/([0-9]+)-([^/\.]*)/?$ index.php?page=Thread&threadID=$2 [L,QSA]
RewriteRule ^([^/\.]+/)*([^/\.]+)/index([0-9]+)\.html$ index.php?page=Board&boardTitle=$2&pageNo=$3 [L,QSA]
RewriteRule ^([^/\.]+/)*([^/\.]+)/?$ index.php?page=Board&boardTitle=$2 [L,QSA]
RewriteRule ^index\.html$ index.php?page=Index [L,QSA]
</IfModule>
# WCF-SEO-END
bbtuxi
 
Beiträge: 50
Registriert: Fr Jan 16, 2009 10:28 pm

Re: Problem bei meiner Webseite?

Beitragvon Lotus » Mo Mai 30, 2011 7:41 pm

Die Weiterleitungsadresse (du schreibt hier: mit www) wurde bereits einmal erfasst.
Es wird nicht weiter verfolgt, weil das durch den Recrawle-nicht-wenn-jünger Filter abgebrochen wird. (Name in YaCy ist etwas anders)
Lotus
 
Beiträge: 1699
Registriert: Mi Jun 27, 2007 3:33 pm
Wohnort: Hamburg

Re: Problem bei meiner Webseite?

Beitragvon bbtuxi » Di Mai 31, 2011 4:08 pm

Genau, mein Problem ist jetzt das ich einen Crawl gestartet habe und dort angeben habe:

Nachladen führe diesen Crawl einmalig aus aber behandle URLs die bereits seit
1 Stunde bekannt sind nicht als Dubletten.....

Und jedesmal kommt die Fehlermeldung?

Bist du sicher das: "redirection to double content" kommt weil die URL schon drin ist? Ich vermute eher Yacy gefällt die 301er Weiterleitung in der Htacces Datei nicht?

grüße
bbtuxi
 
Beiträge: 50
Registriert: Fr Jan 16, 2009 10:28 pm

Re: Problem bei meiner Webseite?

Beitragvon Lotus » Di Mai 31, 2011 5:46 pm

Was passiert, wenn du die Seite auf die weitergeleitet wird mit den selben Parametern als Startpunkt angibst?

Es sieht im Code ganz so aus, als ob für den speziellen Fall der Weiterleitung das Alter nicht geprüft wird. (nach der Meldung suchen)
Lotus
 
Beiträge: 1699
Registriert: Mi Jun 27, 2007 3:33 pm
Wohnort: Hamburg


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 5 Gäste