Can't install YaCy

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

Can't install YaCy

Beitragvon krzyszp » So Mai 25, 2014 3:24 pm

I have a problem on VPS with YaCy installer:
Code: Alles auswählen
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/yacy/cora/order/Base64Order : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: net.yacy.cora.order.Base64Order. Program will exit.
dpkg: error processing yacy (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
yacy
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any advise?
krzyszp
 
Beiträge: 21
Registriert: So Jan 12, 2014 2:40 pm

Re: Can't install YaCy

Beitragvon r00t » Mi Mai 28, 2014 11:25 am

You need a newer version of Java, as some Ubuntu board suggests, jre 1.6 would be sufficient.

You might want to do a quick "java -version" on your server and tell us the version, as well as maybe your OS.

My version which works like a charm:
Code: Alles auswählen
java version "1.7.0_55"
OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-2)
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)


Package on Debian: openjdk-7-jre-headless:amd64
r00t
 
Beiträge: 2
Registriert: Mi Mai 28, 2014 11:03 am

Re: Can't install YaCy

Beitragvon krzyszp » Do Mai 29, 2014 1:19 am

I have resolved this problem by upgrading Ubuntu from 12.04 to 14.04, but now I have another problem:

HTTP ERROR: 403

Problem accessing /. Reason:

proxy use not allowed (see Advanced Settings -> HTTP Networking -> Transparent Proxy; switched off).
Powered by Jetty://


This happens with default install from repository - nothing adjusted jet...
krzyszp
 
Beiträge: 21
Registriert: So Jan 12, 2014 2:40 pm

Re: Can't install YaCy

Beitragvon sixcooler » Do Mai 29, 2014 1:27 am

Hello krzyszp,

how did you call your YaCy?

Do You get this by requesting http://localhost:8090/Status.html ?
Or does this come by accesing Your YaCy from outside?

cu, sixcooler.
sixcooler
 
Beiträge: 492
Registriert: Do Aug 14, 2008 5:22 pm

Re: Can't install YaCy

Beitragvon krzyszp » Do Mai 29, 2014 1:33 am

No, I have domain for it, so I call it - http://startsearch.info:8090 or http://startsearch.info:8090/Status.html - same result.
krzyszp
 
Beiträge: 21
Registriert: So Jan 12, 2014 2:40 pm

Re: Can't install YaCy

Beitragvon sixcooler » Do Mai 29, 2014 1:45 am

Hello krzyszp,

for a workaround try putting Yor domain-name 'startsearch.info' into Your /etc/hosts for Your local asdress.

cu, sixcooler.
sixcooler
 
Beiträge: 492
Registriert: Do Aug 14, 2008 5:22 pm

Re: Can't install YaCy

Beitragvon krzyszp » Do Mai 29, 2014 3:14 am

Already got it, part of hosts:
192.166.218.170 krzyszp.uh.net.pl 7authors.com poloniagb.co.uk krzyszp ebookconverter.eu startsearch.info

(I have multiple domains on this host)

It works now... I have no idea what happens :/
krzyszp
 
Beiträge: 21
Registriert: So Jan 12, 2014 2:40 pm


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron