http://www.yacy-websearch.net...Dev:Solr aktualisieren

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

http://www.yacy-websearch.net...Dev:Solr aktualisieren

Beitragvon fherb » Fr Aug 14, 2015 9:19 pm

Hallo wieder,

eine Bitte diesemal: Die Einrichtung eines externen solr wird auf der Seite http://www.yacy-websearch.net/wiki/index.php/Dev:Solr recht gut und ausreichend beschrieben. Im Prinzip funktioniert es auch noch so bis zur letzten solr-Version der 4er-Reihe. Wie ich gesehen habe, nutzt YaCy inzwischen eingebettet die Version 5.2. Man kann also den Inhalt der eingebetteten Version offenbar nicht so einfach mehr zu einem externen solr über das Dateisystem kopieren. (Oder doch?)

Wäre es möglich, diese Seite bei Gelegenheit mal zu aktualisieren? Denn 5.2 hat einen anderen Aufbau, sodass man die Installationsbeschreibung inzwischen nicht mehr so einfach wiederverwenden kann. Die solr-4...war gibt es zum Beispiel dort nicht mehr oder ist woanders.

Oder kann solr extern mit Version 4.10.x beliebig in der Zukunft für YaCy verwendet werden?

Viele Grüße
Frank
fherb
 
Beiträge: 111
Registriert: Di Nov 26, 2013 10:02 am
Wohnort: Dresden (Germany)

Re: http://www.yacy-websearch.net...Dev:Solr aktualisieren

Beitragvon fherb » Fr Aug 14, 2015 10:33 pm

Vielleicht wäre es dabei ganz praktisch, die Tomcat6-Installation auch über die Paketverwaltung apt-get zu demonstrieren. Das ist sicher spezieller. Aber wer nicht Debian oder Ubuntu benutzt, ist sicher in der Lage, die Beschreibung auf sein System umzudeuten oder unter Debian/Ubuntu auch eine eigene, speziellere Installation abzuleiten (z.B. mit Oracle Java).

Edit: Für die Standard-Tomcat Installation hab ich grad eine schöne Übersicht gefunden, wo sich die Konfigurationsverzeichnisse befinden: http://askubuntu.com/questions/135824/w ... -directory
fherb
 
Beiträge: 111
Registriert: Di Nov 26, 2013 10:02 am
Wohnort: Dresden (Germany)

Re: http://www.yacy-websearch.net...Dev:Solr aktualisieren

Beitragvon Orbiter » Mo Aug 31, 2015 12:27 pm

ja die solr-version ab 5 hat einen leicht anderen Aufbau. Auch die Code-Migration war nicht so einfach. Wir haben das aber nun drin. Die Doku müsste geupdated werden...
Orbiter
 
Beiträge: 5786
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: http://www.yacy-websearch.net...Dev:Solr aktualisieren

Beitragvon fherb » Mo Aug 31, 2015 4:50 pm

Ok. Wenn mal Zeit für Euch sein sollte.

Ich hab inzwischen gelernt, wie ich die Daten über DATA/SURROGATE/in/ von einem zum anderen System bringe. Und wenn Webgraph für mich sowieso keinen Nutzen hat, ist das auch ausreichend. Da kann ich mit der 4er Version von Solr also weiter arbeiten.

Beste Grüße!
fherb
 
Beiträge: 111
Registriert: Di Nov 26, 2013 10:02 am
Wohnort: Dresden (Germany)


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron