YaCy und Java 1.8

Hier finden YaCy User Hilfe wenn was nicht funktioniert oder anders funktioniert als man dachte. Bei offensichtlichen Fehlern diese bitte gleich in die Bugs (http://bugs.yacy.net) eintragen.
Forumsregeln
In diesem Forum geht es um Benutzungsprobleme und Anfragen für Hilfe. Wird dabei ein Bug identifiziert, wird der thread zur Bearbeitung in die Bug-Sektion verschoben. Wer hier also einen Thread eingestellt hat und ihn vermisst, wird ihn sicherlich in der Bug-Sektion wiederfinden.

YaCy und Java 1.8

Beitragvon TmoWizard » Fr Jun 03, 2016 8:13 am

Hallöchen zusammen,

ich hätte da folgendes Problem:

In YaCy 1.83/9838 wird mir derzeit folgende Meldung angezeigt:

YaCy hat geschrieben:Your Java version is old. YaCy currently needs Java 1.7 but we want to migrate to Java 1.8 in the future. Migration to 1.8 won't happen until end of 2016, but we want to join code with YaCy's sister project loklak.org and with a possible re-construction of YaCy in the kaskelix architecture which will be using Java 1.8


Nun gibt es da aber folgende Situation:

Wenn ich Java 1.7 deinstallieren möchte, dann wird automatisch auch YaCy mit deinstalliert! Das bedeutet, daß ich derzeit 2 Versionen von Java hier habe, denn auch 1.8 ist hier schon seit längerem installiert und das entsprechende Plugin wird wenn notwendig von meinem Browser (SeaMonkey [i][i]2.45a2[/i], also eine Testversion!)[/i] auch verwendet:

Pfad: /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so

Was geht denn da schief mit YaCy, denn so ist das ja wohl nicht ganz in Ordnung!

Ansonsten mein Lob zu YaCy, es läuft derzeit als "Principal Peer" stabil und ohne weitere Probleme. 8-)

Grüße aus Augsburg

Mike, TmoWizard
TmoWizard
 
Beiträge: 95
Registriert: So Jul 13, 2014 3:32 pm
Wohnort: Augsburg

Re: YaCy und Java 1.8

Beitragvon luc » Fr Jun 03, 2016 12:18 pm

Hallo,
Ich habe eine offene Pull Request für dieses Problem unter Debian.
Ich glaube @Orbiter oder andere Betreuer sollten nur integrieren.
Entschuldigung für mein schlechtes Deutsch!
luc
 
Beiträge: 266
Registriert: Mi Aug 26, 2015 1:04 am

Re: YaCy und Java 1.8

Beitragvon Orbiter » Mo Jun 06, 2016 7:33 am

Hallo TomWizard, ich glaube luc hat das Problem behoben, ich habe gestern ein neues Debian-Package gebaut so dass du nun auf Java 8 gehen können solltest ohne dass YaCy auch das alte 7 haben will. Danke auch an luc für die schnelle Reaktion.
Bitte berichten obs so geklappt hat.
Orbiter
 
Beiträge: 5784
Registriert: Di Jun 26, 2007 10:58 pm
Wohnort: Frankfurt am Main

Re: YaCy und Java 1.8

Beitragvon TmoWizard » Mo Jun 06, 2016 8:34 am

Guten Morgen @Orbiter und @luc,

das Update kam und nun sieht es so aus:

YaCy hat geschrieben:YaCy Version: 1.83/9857

Java Version: 1.8.0_91


Hat also super geklappt, danke vielmals! Endlich bin ich die alte Version von Java los, wurde auch Zeit. ;)

Einen schönen Tag wünsche ich noch und einen guten Start in die neue Woche.
TmoWizard
 
Beiträge: 95
Registriert: So Jul 13, 2014 3:32 pm
Wohnort: Augsburg

Re: YaCy und Java 1.8

Beitragvon luc » Mo Jun 06, 2016 4:19 pm

Danke @TmoWizard für diese ganze Freundlichkeit!
luc
 
Beiträge: 266
Registriert: Mi Aug 26, 2015 1:04 am


Zurück zu Fragen und Antworten

Wer ist online?

Mitglieder in diesem Forum: YaCy [Bot] und 2 Gäste