Seite 1 von 1

Java 8 to support Solr 6.6

BeitragVerfasst: Fr Jun 09, 2017 10:55 am
von Orbiter
It’s now time to do the migration to Java 1.8.

Deployment is difficult if all systems are already running Java 8 and it is required to install Java 7 to ensure that a deployment is also actually supporting Java 7.
I also had massive issues with Solr on the demo-Server at yacy.searchlab.eu. I hope this gets better with Solr 6.6
But Since Solr 6.0, a Java 1.8 is required.

Migration of the Solr index from 5.5 to 6.6 will happen automatically. It will not be possible to migrate a Solr Index 4.x to 6.6 but that should not be an issue. Everyone who has still a very old YaCy and wants to migrate, just migrate first to YaCy 1.92 and everything will be fine.

Please spread the news that everyone should now install Java 8.

Re: Java 8 to support Solr 6.6

BeitragVerfasst: Fr Jun 09, 2017 12:37 pm
von Orbiter